polymer_fontawesome 0.0.1

  • README.md
  • Installing
  • Versions
  • new59

Font Awesome as a PolymerElements/iron-iconset-svg component.

Set Up pubsec.yaml

# bower
bower install fontawesome-iconset
# npm
npm install fontawesome-iconset


Be sure you import next items from your repositories something like

Link your custom component alongside with other Polymer dependencies (in index.html for instance)

<link rel="import" href="packages/polymer_fontawesome/fa-all.html">

Use the iconset

<iron-icon icon="fa:line-chart"></iron-icon>

You also can refer to an specific category of icons:

<link rel="import" href="packages/polymer_fontawesome/fa-gender.html">

And use it like this:

<iron-icon icon="fa-gender:venus"></iron-icon>


To update to the latest version of FontAwesome, just install node modules and run "update"

npm install
npm run update

Soon there will be a production script to export only the icons to be used (like the original font-awesome-polymer-icons-generator but in node).



  • Initial version

1. Depend on it

Add this to your package's pubspec.yaml file:

  polymer_fontawesome: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.0.1 Jan 24, 2018 Go to the documentation of polymer_fontawesome 0.0.1 Download polymer_fontawesome 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
18 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, web, other

No libraries.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use polymer_fontawesome.dart.