Import the element dart as normal, but note the target dart differes from the package name, in order to keep consistency with the polymer element.
Within html, the component is named 'paper-typeahead-input'.
Examples may be served in debug/release mode via pub.
pub serve examples
The original polymer tests are in the process of being ported. The ported tests can be run as normal dart tests. For example, to run on dartium (default):
pub run test As usual, tests can be run on other platforms with
pub serve test --port=8080 from one terminal and
pub run test -pchrome --pub-serve=8080 from a second.
Note that tests are specifically blocked from running on Firefox currently in order to utilize Travis CI.
Although not necessary for normal use, this package can be rebuilt from the original polymer source using the procedure below. The specific version used as a basis can be specified in bower.json.
pub run custom_element_apigen:update paper_typeahead_input_dart.yaml
For more information on using custom_element_apigen, see https://pub.dartlang.org/packages/custom_element_apigen
Add this to your package's pubspec.yaml file:
dependencies: polymer_paper_typeahead_input: ^0.0.5
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.5||Sep 8, 2016|
|0.0.4||Aug 8, 2016|
|0.0.3||Aug 3, 2016|
|0.0.2||Jul 27, 2016|
|0.0.1||Jul 27, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.13.0 <2.0.0|