polymerize_common 1.0.2

  • README.md
  • Installing
  • Versions
  • 44

Polymer 2.0 support package for polymerize

This package contains the polymer 2.0.0 runtime stubs and other support stuff for projects based on polymerize tool and relate bazel rules for polymerize Dart.

For more info see : Dart Polymer Community site.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  polymerize_common: "^1.0.2"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:polymerize_common/html_import.dart';

      import 'package:polymerize_common/init.dart';

      import 'package:polymerize_common/map.dart';
Version Uploaded Documentation Archive
1.0.2 Jun 23, 2017 Go to the documentation of polymerize_common 1.0.2 Download polymerize_common 1.0.2 archive
1.0.1 Jun 13, 2017 Go to the documentation of polymerize_common 1.0.1 Download polymerize_common 1.0.1 archive
1.0.0 May 21, 2017 Go to the documentation of polymerize_common 1.0.0 Download polymerize_common 1.0.0 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
5 / 100
Code health derived from static analysis. [more]
86 / 100
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in libraries.


  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use polymerize_common.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Run dartfmt to format lib/html_import.dart.

    Run dartfmt to format lib/map.dart.