For more info see : Dart Polymer Community site.
Add this to your package's pubspec.yaml file:
dependencies: polymerize_common: ^1.0.2
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:polymerize_common/html_import.dart'; import 'package:polymerize_common/init.dart'; import 'package:polymerize_common/map.dart';
|1.0.2||Jun 23, 2017|
|1.0.1||Jun 13, 2017|
|1.0.0||May 21, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Document public APIs (-9.23 points)
12 out of 13 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.
dartfmt to format
dartfmt to format
Add SDK constraint in
pubspec.yaml. (-50 points)
For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.
CHANGELOG.md. (-20 points)
Changelog entries help clients to follow the progress in your code.
Package is getting outdated. (-45.21 points)
The package was released 75 weeks ago.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use