pref_gen_flutter 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 46

pref_gen_flutter #

pref_gen's implementation of the shared preferences adapter to use with the generator. For more information about the package visit the homepage or the generator page README.

0.0.1 #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pref_gen_flutter: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pref_gen_flutter/pref_gen_flutter.dart';
  
Version Uploaded Documentation Archive
0.0.2 Dec 31, 2018 Go to the documentation of pref_gen_flutter 0.0.2 Download pref_gen_flutter 0.0.2 archive
0.0.1 Dec 30, 2018 Go to the documentation of pref_gen_flutter 0.0.1 Download pref_gen_flutter 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Apr 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and pref_gen_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
pref_gen_annotations ^0.0.1 0.0.2
shared_preferences ^0.4.3 0.4.3 0.5.2
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8