preference_helper 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new47

preference_helper #

Pub

A package that makes shared_preferences easier to use, This package is built with bloc, shared_preferences

Usage #

Check example project

0.0.4 #

  • Change bloc init state to loaded preference state
  • Remove PreferenceLoading, PreferenceLoaded state
  • Rename FetchPreference event to UpdatePreference

0.0.3 #

  • Add documentation comments
  • Change getPreferences method to public

0.0.2 #

  • Apply package layout convention

0.0.1 #

  • Initial releasetm

example/README.md

preference_helper_example #

Example of use preference_helper

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  preference_helper: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:preference_helper/preference_helper.dart';
  
Version Uploaded Documentation Archive
0.0.4 Mar 23, 2019 Go to the documentation of preference_helper 0.0.4 Download preference_helper 0.0.4 archive
0.0.3 Mar 23, 2019 Go to the documentation of preference_helper 0.0.3 Download preference_helper 0.0.3 archive
0.0.2 Mar 20, 2019 Go to the documentation of preference_helper 0.0.2 Download preference_helper 0.0.2 archive
0.0.1 Mar 12, 2019 Go to the documentation of preference_helper 0.0.1 Download preference_helper 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
83
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Mar 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
bloc ^0.9.5 0.9.5 0.10.0
equatable ^0.2.3 0.2.3
flutter 0.0.0
meta ^1.1.6 1.1.6 1.1.7
shared_preferences ^0.5.1+1 0.5.1+2
Transitive dependencies
collection 1.14.11
rxdart 0.20.0 0.21.0
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test