presubmit 0.0.2

  • README.md
  • Installing
  • Versions
  • 0

presubmit

A batteries included package to validate whether the working revision of a Dart package conforms to testing and contribution requirements. Stated simply, "something to run on continuous integration before merging pull requests".

Usage

$ pub global activate presubmit

$ pub global run presubmit \
$   --[no]dartanalyzer \
$   --[no]dartfmt \
$   --[no]tests \
$   --path <location of package, defaults to current>

Planned work

A high-level list of work required to get this close to an initial release:

Running modes

  • [x] Allow running as a binary (i.e. pub run presubmit)
  • [x] Allow specifying binary arguments via the command-line
  • [ ] Allow specifying binary arguments via presubmit.yaml
  • [ ] Allow programmatic use, i.e. write your own tool/presubmit.dart

Built-in plugins

  • [x] Run the Dart analyzer and linter
  • [x] Run the Dart formatter
  • [x] Run the Dart test runner (pub run test)
  • [ ] Run an offline source generator (i.e. a build.dart file)

Extensibility

  • [ ] Allow defining your own plugin (unclear how this works yet)
  • [ ] Run nested sets of plugins (i.e. run program, run tests, close program)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  presubmit: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.0.2 Feb 25, 2017 Go to the documentation of presubmit 0.0.2 Download presubmit 0.0.2 archive
0.0.1 Jan 20, 2017 Go to the documentation of presubmit 0.0.1 Download presubmit 0.0.1 archive
0.0.0 Jan 20, 2017 Go to the documentation of presubmit 0.0.0 Download presubmit 0.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0-dev.1.0 <2.0.0