A batteries included package to validate whether the working revision of a Dart package conforms to testing and contribution requirements. Stated simply, "something to run on continuous integration before merging pull requests".
$ pub global activate presubmit $ pub global run presubmit \ $ --[no]dartanalyzer \ $ --[no]dartfmt \ $ --[no]tests \ $ --path <location of package, defaults to current>
A high-level list of work required to get this close to an initial release:
pub run presubmit)
pub run test)
Add this to your package's pubspec.yaml file:
dependencies: presubmit: ^0.0.2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
|0.0.2||Feb 25, 2017|
|0.0.1||Jan 20, 2017|
|0.0.0||Jan 20, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.23.0-dev.1.0 <2.0.0|