pretty 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Pretty-Printing Combinators

A Dart port of Christian Lindig's strict version of Wadler's pretty-printing combinators. The present version deforests away the second intermediate tree of Lindig's implementation, which should make it slightly more efficient.

Please refer to the tutorial and the API docs.

Changelog for pretty

0.2.0

  • Make strong mode compliant

0.1.0

  • Add lineOr

0.0.9

  • Move run_all_tests.sh to tests/run.sh to adhere to pub.drone.io's conventions

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pretty: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pretty/pretty.dart';
  
Version Uploaded Documentation Archive
0.2.0 Mar 2, 2018 Go to the documentation of pretty 0.2.0 Download pretty 0.2.0 archive
0.1.1 Nov 6, 2014 Go to the documentation of pretty 0.1.1 Download pretty 0.1.1 archive
0.1.0 Nov 6, 2014 Go to the documentation of pretty 0.1.0 Download pretty 0.1.0 archive
0.0.9 Sep 18, 2014 Go to the documentation of pretty 0.0.9 Download pretty 0.0.9 archive
0.0.8 Nov 8, 2013 Go to the documentation of pretty 0.0.8 Download pretty 0.0.8 archive
0.0.7 Nov 5, 2013 Go to the documentation of pretty 0.0.7 Download pretty 0.0.7 archive
0.0.6 Oct 1, 2013 Go to the documentation of pretty 0.0.6 Download pretty 0.0.6 archive
0.0.5 Sep 27, 2013 Go to the documentation of pretty 0.0.5 Download pretty 0.0.5 archive
0.0.4 Sep 26, 2013 Go to the documentation of pretty 0.0.4 Download pretty 0.0.4 archive
0.0.3 Sep 26, 2013 Go to the documentation of pretty 0.0.3 Download pretty 0.0.3 archive

All 12 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0