principal 0.2.0

  • Installing
  • Versions
  • 23


Permissions and identity for Dart.

API Reference Documentation

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  principal: "^0.2.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:principal/principal.dart';
Version Uploaded Documentation Archive
0.2.0 Dec 28, 2012 Go to the documentation of principal 0.2.0 Download principal 0.2.0 archive
0.1.0 Dec 28, 2012 Go to the documentation of principal 0.1.0 Download principal 0.1.0 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
78 / 100
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:principal/principal.dart.


  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: unittest.

  • Package is too old.

    The package was released more than two years ago.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 1 hint.

    Strong-mode analysis of lib/principal.dart failed with the following error:

    line: 24 col: 3
    Invalid override. The type of 'Requirement.==' ('(Requirement<T>) → bool') isn't a subtype of 'Object.==' ('(dynamic) → bool').

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use principal.dart.


Package Constraint Resolved Available
Direct dependencies
unittest any 0.12.3 0.12.4+1
Transitive dependencies
analyzer 0.25.0+1 0.32.1
args 0.13.7 1.4.3
async 1.13.3 2.0.7
barback 0.15.2+16
charcode 1.1.1
collection 1.14.10
convert 1.1.1 2.0.1
crypto 0.9.2+1 2.0.5
glob 1.1.5
http 0.11.3+16
http_multi_server 1.3.2 2.0.5
http_parser 0.0.2+8 3.1.2
matcher 0.12.0+2 0.12.3
mime 0.9.6+1
package_config 1.0.3
package_resolver 1.0.3
path 1.6.1
pool 1.3.5
pub_semver 1.4.1
shelf 0.6.3 0.7.3+1
shelf_static 0.2.7+1
shelf_web_socket 0.0.1+5 0.2.2+2
source_map_stack_trace 1.1.4
source_maps 0.10.5
source_span 1.4.0
stack_trace 1.9.2
string_scanner 0.1.5 1.0.2
test 0.12.3+9 1.0.0
typed_data 1.1.5
watcher 0.9.7+8
yaml 2.1.14