process 3.0.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 96

Process

Build Status - Coverage Status -

A generic process invocation abstraction for Dart.

Like dart:io, package:process supplies a rich, Dart-idiomatic API for spawning OS processes.

Unlike dart:io, package:process:

  • Can be used to implement custom process invocation backends.
  • Comes with a record-replay implementation out-of-the-box, making it super easy to test code that spawns processes in a hermetic way.

3.0.5

  • Fixes for missing_return analysis errors with 2.10.0-dev.1.0.

3.0.4

  • Fix unit tests
  • Update SDK constraint to 3.

3.0.3

  • Update dependency on package:file

3.0.2

  • Remove upper case constants.
  • Update SDK constraint to 2.0.0-dev.54.0.
  • Fix tests for Dart 2.

3.0.1

  • General cleanup

3.0.0

  • Cleanup getExecutablePath() to better respect the platform

2.0.9

  • Bumped package:file dependency

2.0.8

  • Fixed method getArguments to qualify the map method with the specific String type

2.0.7

  • Remove set exitCode instances

2.0.6

  • Fix SDK constraint.
  • rename .analysis_options file to analaysis_options.yaml.
  • Use covariant in place of @checked.
  • Update comment style generics.

2.0.5

  • Bumped maximum Dart SDK version to 2.0.0-dev.infinity

2.0.4

  • relax dependency requirement for intl

2.0.3

  • relax dependency requirement for platform

2.0.2

  • Fix a strong mode function expression return type inference bug with Dart 1.23.0-dev.10.0.

2.0.1

  • Fixed bug in ReplayProcessManager whereby it could try to write to stdout or stderr after the streams were closed.

2.0.0

  • Bumped package:file dependency to 2.0.1

1.1.0

  • Added support to transparently find the right executable under Windows.

1.0.1

  • The executable and arguments parameters have been merged into one command parameter in the run, runSync, and start methods of ProcessManager.
  • Added support for sanitization of command elements in RecordingProcessManager and ReplayProcessManager via the CommandElement class.

1.0.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  process: ^3.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:process/process.dart';
  
Version Uploaded Documentation Archive
3.0.5 Aug 13, 2018 Go to the documentation of process 3.0.5 Download process 3.0.5 archive
3.0.4 Aug 13, 2018 Go to the documentation of process 3.0.4 Download process 3.0.4 archive
3.0.3 Jul 24, 2018 Go to the documentation of process 3.0.3 Download process 3.0.3 archive
3.0.1 Apr 10, 2018 Go to the documentation of process 3.0.1 Download process 3.0.1 archive
3.0.0 Apr 9, 2018 Go to the documentation of process 3.0.0 Download process 3.0.0 archive
2.0.9 Mar 20, 2018 Go to the documentation of process 2.0.9 Download process 2.0.9 archive
2.0.8 Mar 7, 2018 Go to the documentation of process 2.0.8 Download process 2.0.8 archive
2.0.7 Jan 2, 2018 Go to the documentation of process 2.0.7 Download process 2.0.7 archive
2.0.6 Nov 1, 2017 Go to the documentation of process 2.0.6 Download process 2.0.6 archive
2.0.5 Jul 13, 2017 Go to the documentation of process 2.0.5 Download process 2.0.5 archive

All 18 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95
Overall:
Weighted score of the above. [more]
96
Learn more about scoring.

We analyzed this package on Aug 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: Flutter, other

Primary library: package:process/process.dart with components: io.

Issues and suggestions

Use constrained dependencies.

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: platform.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use process.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.61 <3.0.0
file ^5.0.0 5.0.4
intl >=0.14.0 <0.16.0 0.15.7
meta ^1.1.2 1.1.6
path ^1.5.1 1.6.2
platform >=1.0.1 2.2.0
Dev dependencies
test ^1.0.0