process_plus 1.0.0

  • Installing
  • Versions
  • 0


Pub build status

Helpers for package:process. Including ForwardingProcessManager, PooledProcessManager, MockProcessManager, and CompletedProcess.


A simple ProcessManager that delegates to another one. Typically used as a base class to extend functionality.

var manager = new ForwwardingProcessManager(const LocalProcessManager());


A ProcessManager that uses a Pool to limit to the max amount of concurrently-running processes.

var manager = new PooledProcessManager(const LocalProcessManager(), Platform.numberOfProcessors);


A ProcessManager that can enqueue results in advance, rather than actually spawning OS processes.

var manager = new MockProcessManager();
manager.enqueue(new ProcessResult(0, 1337, stdout, stderr));

var p = await['foo', '--bar=baz']);
await p.exitCode; // 1337


A Process implementation that simply outputs the result of a CompletedProcess.

var p = new CompletedProcess(new ProcessResult(0, 1337, stdout, stderr));
await p.exitCode; // 1337

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  process_plus: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:process_plus/process_plus.dart';
Version Uploaded Documentation Archive
1.0.0 Mar 2, 2018 Go to the documentation of process_plus 1.0.0 Download process_plus 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0