prompter_aum 0.0.1

  • Example
  • Installing
  • Versions
  • new47

example/main.dart

import 'package:prompter_aum/prompter_aum.dart';

void main() {
  
  final options = [
    new Option('Shiva maha mantra', 'aum namah shivaya'),
    new Option('Narayana maha mantra', 'aum namo narayana')
  ];
  
  final prompter = new Prompter();

  String mahaMantram = prompter.askMultiple('Select maha mantram', options);

  bool answer = prompter.askBinary("Do you like shiva?");
  
  print(mahaMantram);
  print(answer);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_aum: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:prompter_aum/prompter_aum.dart';
  
Version Uploaded Documentation Archive
0.0.1 Jul 1, 2018 Go to the documentation of prompter_aum 0.0.1 Download prompter_aum 0.0.1 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
11 / 100
Health:
Code health derived from static analysis. [more]
90 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76 / 100
Overall score:
Weighted score of the above. [more]
47
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_aum/prompter_aum.dart with components: io.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 4 hints.

    Run dartfmt to format lib/prompter_aum.dart.

    Run dartfmt to format lib/src/option.dart.

    Similar analysis of the following files failed:

    • lib/src/prompter.dart (hint)
    • lib/src/terminal.dart (hint)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0