prompter_dhg 0.0.2

  • Example
  • Installing
  • Versions
  • 34

example/main.dart

import 'package:prompter_dhg/prompter_dhg.dart';

void main() {
  final options = [
    new Option('I want red', '#f00'),
    new Option('I want blue', '#00f')
  ];

  final prompter = new Prompter();

  String colorCode = prompter.askMultiple('What u want', options);

  bool answer = prompter.askBinary('Do you like Dart? ');

  print(colorCode);
  print(answer);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_dhg: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_dhg/prompter_dhg.dart';
  
Version Uploaded Documentation Archive
0.0.2 Jul 6, 2018 Go to the documentation of prompter_dhg 0.0.2 Download prompter_dhg 0.0.2 archive
0.0.1 Jul 6, 2018 Go to the documentation of prompter_dhg 0.0.1 Download prompter_dhg 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
20
Overall:
Weighted score of the above. [more]
34
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_dhg/prompter_dhg.dart with components: io.

Maintenance issues and suggestions

Maintain README.md. (-30 points)

Readme should inform others about your project, what it does, and how they can use it.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0