prompter_fl 0.0.1

  • README.md
  • Example
  • Installing
  • Versions
  • new39

Prompter

example/main.dart

import 'package:prompter_fl/prompter_fl.dart';

void main() {
  final options = <Option>[
    Option('Salvador', 'Salvador'),
    Option('Lauro de Freitas', 'Lauro de Freitas') 
  ];

  final prompter = Prompter();
  final value = prompter.askBinary("Você é baiano?");

  print("Selected value: $value");

  if(value) {
    final value2 = prompter.askWithOptions("Qual cidade?", options);
    print("Selected value: $value2");
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_fl: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_fl/prompter_fl.dart';
  
Version Uploaded Documentation Archive
0.0.1 Nov 27, 2018 Go to the documentation of prompter_fl 0.0.1 Download prompter_fl 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
3
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
39
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_fl/prompter_fl.dart with components: io.

Health issues and suggestions

Document public APIs (-10 points)

9 out of 9 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Format lib/prompter_fl.dart.

Run dartfmt to format lib/prompter_fl.dart.

Format lib/src/option.dart.

Run dartfmt to format lib/src/option.dart.

Format lib/src/prompter.dart.

Run dartfmt to format lib/src/prompter.dart.

Format lib/src/terminal.dart.

Run dartfmt to format lib/src/terminal.dart.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0