prompter_flut 0.0.2

  • README.md
  • Example
  • Installing
  • Versions
  • 40

README.dm

example/main.dart

import 'package:prompter_flut/prompter_flut.dart';


void main() {
  final options = [
    Option("I want red", "#f00"),
    Option("I want blue", "#00f"),
  ];

  final prompter = Prompter();
  final selection = prompter.askMultiple("What color do you refer?", options);
  print(selection);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_flut: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_flut/prompter_flut.dart';
  
Version Uploaded Documentation Archive
0.0.2 Jan 11, 2019 Go to the documentation of prompter_flut 0.0.2 Download prompter_flut 0.0.2 archive
0.0.1 Jan 11, 2019 Go to the documentation of prompter_flut 0.0.1 Download prompter_flut 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Apr 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_flut/prompter_flut.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

11 out of 11 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/prompter_flut.dart.

Run dartfmt to format lib/prompter_flut.dart.

Format lib/src/option.dart.

Run dartfmt to format lib/src/option.dart.

Format lib/src/terminal.dart.

Run dartfmt to format lib/src/terminal.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0