prompter_rk 0.0.1

  • Example
  • Installing
  • Versions
  • new43

Library to create CLI wizards


import 'package:prompter_rk/prompter_rk.dart';

void main() {
  final options = [
    new Option("I want red", '#f00'),
    new Option("I want blue", '#00f')

  final prompter = new Prompter();

  final color = prompter.askMultiple('What color do you want?', options);
  bool likesDart = prompter.askBinary("Do you like dart?");

      "You prefer ${color.value} and ${likesDart ? "like" : "don't like"} dart");

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  prompter_rk: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:prompter_rk/prompter_rk.dart';
Version Uploaded Documentation Archive
0.0.1 Sep 16, 2018 Go to the documentation of prompter_rk 0.0.1 Download prompter_rk 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3


Detected platforms: Flutter, other

Primary library: package:prompter_rk/prompter_rk.dart with components: io.

Issues and suggestions


Changelog entries help clients to follow the progress in your code.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release.

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Format lib/prompter_rk.dart.

Run dartfmt to format lib/prompter_rk.dart.

Format lib/src/option.dart.

Run dartfmt to format lib/src/option.dart.

Format lib/src/terminal.dart.

Run dartfmt to format lib/src/terminal.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0