proxy_scraper 1.0.0-dev+1

  • Installing
  • Versions
  • 0

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate proxy_scraper

2. Use it

The package has the following executables:

$ proxy_scraper

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  proxy_scraper: ^1.0.0-dev+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:proxy_scraper/proxy_scraper.dart';
Version Uploaded Documentation Archive
1.0.0-dev+1 Aug 18, 2016 Go to the documentation of proxy_scraper 1.0.0-dev+1 Download proxy_scraper 1.0.0-dev+1 archive
1.0.0-dev Aug 18, 2016 Go to the documentation of proxy_scraper 1.0.0-dev Download proxy_scraper 1.0.0-dev archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health issues and suggestions

Fix lib/src/proxy_client.dart. (-59.06 points)

Analysis of lib/src/proxy_client.dart failed with 3 errors, 6 hints, including:

line 104 col 64: The element type 'int' can't be assigned to the map value type 'String'.

line 109 col 54: The argument type 'int' can't be assigned to the parameter type 'String'.

line 116 col 32: The method 'toLowercase' isn't defined for the class 'String'.

line 104 col 48: 'CONTENT_LENGTH' is deprecated and shouldn't be used.

line 125 col 24: Equality operator == invocation with references of unrelated types.

Fix lib/src/proxy_checker.dart. (-25.38 points)

Analysis of lib/src/proxy_checker.dart failed with 1 error, 1 hint:

line 11 col 7: Missing concrete implementation of StreamTransformer.cast.

line 47 col 17: The value of the local variable 'response' isn't used.

Fix lib/src/proxy_stream.dart. (-25 points)

Analysis of lib/src/proxy_stream.dart failed with 1 error:

line 5 col 7: Missing concrete implementation of StreamTransformer.cast.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • bin/proxy_scraper.dart (Run dartfmt to format bin/proxy_scraper.dart.)
  • lib/src/proxy_def.dart (Run dartfmt to format lib/src/proxy_def.dart.)
  • lib/src/proxy_scraper.dart (Run dartfmt to format lib/src/proxy_scraper.dart.)

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain (-30 points)

Readme should inform others about your project, what it does, and how they can use it.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use proxy_scraper.dart. Packages with multiple examples should use example/


Package Constraint Resolved Available
Direct dependencies
http >=0.11.3 <1.0.0 0.12.0
merge_map >=1.0.0 <2.0.0 1.0.1
yaml >=2.0.0 <3.0.0 2.1.15
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6
path 1.6.2
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
Dev dependencies
dotenv >=0.1.3+3 <1.0.0
test >=0.12.13 <1.0.0