proxy_scraper 1.0.0-dev+1

  • Installing
  • Versions
  • 7

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate proxy_scraper

2. Use it

The package has the following executables:


$ proxy_scraper

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  proxy_scraper: ^1.0.0-dev+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:proxy_scraper/proxy_scraper.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev+1 Aug 18, 2016 Go to the documentation of proxy_scraper 1.0.0-dev+1 Download proxy_scraper 1.0.0-dev+1 archive
1.0.0-dev Aug 18, 2016 Go to the documentation of proxy_scraper 1.0.0-dev Download proxy_scraper 1.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
23
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
7
Learn more about scoring.

We analyzed this package on Aug 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: Flutter, other

Primary library: package:proxy_scraper/proxy_scraper.dart with components: io.

Issues and suggestions

Fix lib/src/proxy_client.dart.

Analysis of lib/src/proxy_client.dart failed with 3 errors, 6 hints, including:

line 104 col 64: The element type 'int' can't be assigned to the map value type 'String'.

line 109 col 54: The argument type 'int' can't be assigned to the parameter type 'String'.

line 116 col 32: The method 'toLowercase' isn't defined for the class 'String'.

line 104 col 48: 'CONTENT_LENGTH' is deprecated and shouldn't be used.

line 125 col 24: Equality operator == invocation with references of unrelated types.

Fix lib/src/proxy_checker.dart.

Analysis of lib/src/proxy_checker.dart failed with 1 error, 1 hint:

line 11 col 7: Missing concrete implementation of 'StreamTransformer.cast'.

line 47 col 17: The value of the local variable 'response' isn't used.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Maintain README.md.

Readme should inform others about your project, what it does, and how they can use it.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/proxy_stream.dart (1 error)
  • lib/src/proxy_def.dart (Run dartfmt to format lib/src/proxy_def.dart.)
  • lib/src/proxy_scraper.dart (Run dartfmt to format lib/src/proxy_scraper.dart.)

Package is getting outdated.

The package was released 103 weeks ago.

Package is pre-release.

Pre-release versions should be used with caution, their API may change in breaking ways.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use proxy_scraper.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
http >=0.11.3 <1.0.0 0.11.3+17
merge_map >=1.0.0 <2.0.0 1.0.1
yaml >=2.0.0 <3.0.0 2.1.15
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
path 1.6.2
source_span 1.4.1
string_scanner 1.0.3
typed_data 1.1.6
Dev dependencies
dotenv >=0.1.3+3 <1.0.0
test >=0.12.13 <1.0.0