pub_mediator 1.0.1

  • README.md
  • Installing
  • Versions
  • 70

pub_mediator

Pub build status

Diagnoses version conflicts between dependencies in Dart packages.

About

Without mediator, it is rather cumbersome to resolve dependency conflicts within Dart projects. You would receive a relatively cryptic error message that doesn't tell you much in the way of resolving conflicts:

Package jaguar_serializer has no versions that match >=0.3.0 <0.4.0 derived from:
- gitter 0.1.1 depends on version ^0.3.0

mediator provides you with details about where the mismatches are:

✗ Found 1 dependency conflict:
Found 2 mismatching dependencies on package:crypto:
  * foo requires  <1.0.0
  * angel_auth requires  ^2.0.0

mediator also tracks nested dependencies. Dependency mismatches don't always happen at the top level, but often within the dependencies of other dependencies.

✗ Found 1 dependency conflict:
Found 2 mismatching dependencies on package:crypto:
  * foo requires  <1.0.0
  * bar->baz->quux requires  ^2.0.0

Installation and Usage

pub global activate pub_mediator

Run the following in your project root:

mediator

# Enable verbose output
mediator -v

# Print help
mediator -h

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate pub_mediator

2. Use it

The package has the following executables:


$ mediator

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pub_mediator: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pub_mediator/pub_mediator.dart';
  
Version Uploaded Documentation Archive
1.0.1 Sep 2, 2017 Go to the documentation of pub_mediator 1.0.1 Download pub_mediator 1.0.1 archive
1.0.0 Jul 13, 2017 Go to the documentation of pub_mediator 1.0.0 Download pub_mediator 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
64
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because pub_mediator depends on pubspec >=0.0.1+1 which requires SDK version >=1.9.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use pub_mediator.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0