Diagnoses version conflicts between dependencies in Dart packages.
mediator, it is rather cumbersome to resolve dependency conflicts within Dart projects.
You would receive a relatively cryptic error message that doesn't tell you much in the way of
Package jaguar_serializer has no versions that match >=0.3.0 <0.4.0 derived from: - gitter 0.1.1 depends on version ^0.3.0
mediator provides you with details about where the mismatches are:
✗ Found 1 dependency conflict: Found 2 mismatching dependencies on package:crypto: * foo requires <1.0.0 * angel_auth requires ^2.0.0
mediator also tracks nested dependencies. Dependency mismatches don't always happen at the
top level, but often within the dependencies of other dependencies.
✗ Found 1 dependency conflict: Found 2 mismatching dependencies on package:crypto: * foo requires <1.0.0 * bar->baz->quux requires ^2.0.0
pub global activate pub_mediator
Run the following in your project root:
mediator # Enable verbose output mediator -v # Print help mediator -h
You can install the package from the command line:
$ pub global activate pub_mediator
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: pub_mediator: "^1.0.1"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.1||Sep 2, 2017|
|1.0.0||Jul 13, 2017|
We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Changelog entries help clients to follow the progress in your code.
Fix analysis and formatting issues.
Analysis or formatting checks reported 2 errors 2 hints.
Strong-mode analysis of
lib/src/diagnose.dartfailed with the following error:
line: 51 col: 22
The argument type 'List' can't be assigned to the parameter type 'Iterable<Future>'.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use