pub_util 0.0.3

  • Installing
  • Versions
  • 0

pub_util Build Status Build status on windows

pub_util is a utility that can help list and update globally installed outdated Dart packages.

The hope is that this functionality will eventually be available in the standard pub global command.


pub global activate pub_util


pub_util can list all and outdated packages and update outdated packages.

  1. List all globally installed packages
pub_util -l
  1. List all outdated global packages
pub_util -o
  1. Update all outdated global packages
pub_util -u

Bugs, Fixes, Enhancements

All feedback, PRs and bug reports are welcome.

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate pub_util

2. Use it

The package has the following executables:

$ pub_util
Version Uploaded Documentation Archive
0.0.3 Dec 2, 2016 Go to the documentation of pub_util 0.0.3 Download pub_util 0.0.3 archive
0.0.2 Dec 2, 2016 Go to the documentation of pub_util 0.0.2 Download pub_util 0.0.2 archive
0.0.1 Dec 2, 2016 Go to the documentation of pub_util 0.0.1 Download pub_util 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0