pubglobalupdate 0.3.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 49

pubglobalupdate.dart

Command (Linux/Mac/Windows) to update all current global activated packages (git, path or hosted) to their latest version

Build Status

Activate

pub global activate pubglobalupdate

Usage

Usage: pubglobalupdate [<pkg1> <pkg2>...]

By default all packages are updated

Global options:
-h, --help       Usage help
    --version    Display version
-v, --verbose    Verbose
-d, --dry-run    Do not run test, simple show the command executed

Update all current activated packages

$ pubglobalupdate

Update one package

$ pubglobalupdate stagehand

Dev

  • before commit, run all unit tests
  • to activate from your local drive: pub global activate -s path .
  • to activate from git repository: pub global activate -s git git://github.com/tekartik/pubglobalupdate.dart

Dependencies

Changelog

0.3.3

  • Add implicit-cast: false support

0.3.2

  • Update dependencies to their latest version
  • doc update

0.3.1

  • Use process_run 0.5.0

0.3.0

  • Initial version

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate pubglobalupdate

2. Use it

The package has the following executables:


$ pubglobalupdate
Version Uploaded Documentation Archive
0.3.3 Mar 1, 2018 Go to the documentation of pubglobalupdate 0.3.3 Download pubglobalupdate 0.3.3 archive
0.3.2 Oct 25, 2017 Go to the documentation of pubglobalupdate 0.3.2 Download pubglobalupdate 0.3.2 archive
0.3.1 Sep 28, 2016 Go to the documentation of pubglobalupdate 0.3.1 Download pubglobalupdate 0.3.1 archive
0.3.0 Nov 27, 2015 Go to the documentation of pubglobalupdate 0.3.0 Download pubglobalupdate 0.3.0 archive

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95 / 100
Overall score:
Weighted score of the above. [more]
49
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

  • Use constrained dependencies.

    The pubspec.yaml contains 4 dependencies without version constraints. Specify version ranges for the following dependencies: args, path, process_run, pub_semver.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use pubglobalupdate.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0
args >=1.0.2 1.4.3
path >=1.4.2 1.6.0
process_run >=0.5.5 0.5.6
pub_semver >=1.3.2 1.4.1
Transitive dependencies
collection 1.14.10
Dev dependencies
dev_test >=0.9.3
test >=0.12.26