pubinit 0.0.4

  • README.md
  • Installing
  • Versions
  • 0

pubinit

A simple dart command line utility to boostrap the pubspec.yaml file in a dart project

Inspired from the npm init command.

Install

Just run pub global activate pubinit
or
pub global activate --source git https://github.com/shalien/pubinit.git

Usage

Just run pub global run pubinit in the folder you want to create your pubspec.yaml

#Contributing Feel to free to send issues and merge request !

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate pubinit

2. Use it

The package has the following executables:


$ pubinit
Version Uploaded Documentation Archive
0.0.4 Apr 14, 2017 Go to the documentation of pubinit 0.0.4 Download pubinit 0.0.4 archive
0.0.3 Apr 14, 2017 Go to the documentation of pubinit 0.0.3 Download pubinit 0.0.3 archive
0.0.2 Apr 14, 2017 Go to the documentation of pubinit 0.0.2 Download pubinit 0.0.2 archive
0.0.1 Apr 14, 2017 Go to the documentation of pubinit 0.0.1 Download pubinit 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0