🧔 The package that will help you out with Dart's Pub 🎯
Bring publican to your global dependencies:
pub global activate publican
mkdir my_awesome_app cd my_awesome_app publican init
It will generate a
pubspec.yaml file with the following defaults:
name: my_app version: 0.1.0 description: My awesome Dart app
You can override default values throught the options:
-n, --name (defaults to "my_app") -v, --version (defaults to "0.1.0") -d, --description (defaults to "My awesome Dart app")
Note: it will not override your current pubspec.yaml file, if you already have one, its safe.
Adds a dependency to
publican add angular angular_components
Publican will already look for the latest stable version:
name: my_app version: 0.1.0 description: My awesome Dart app dependencies: angular_components: ^0.8.0 angular: ^4.0.0+2
⚠️ Also, it will not change your previous YAML structure definitions, that is a key difference from Publican to other similar packages.
--dev flag will add the dependencies to
publican add --dev build_runner build_web_compilers
name: my_app version: 0.1.0 description: My awesome Dart app dependencies: angular_components: ^0.8.0 angular: ^4.0.0+2 dev_dependencies: build_web_compilers: ^0.3.4+2 build_runner: ^0.8.0
If you are not sure about the output, you can check it out before by adding the
--dry-run flag, then it will print out what it would write.
You can also constraint a dependency to a specific version using an
publican add angular@^1.1.2+2
Want to try bleeding edge versions of you dependencies? Just add the
publican add -a angular
dependencies: angular: ^5.0.0-alpha+8
BSD 3-Clause License
Copyright (c) 2018, Leo Cavalcante All rights reserved.
You can install the package from the command line:
$ pub global activate publican
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: publican: ^0.1.3
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.3||Mar 25, 2018|
|0.1.2||Mar 25, 2018|
|0.1.1||Mar 24, 2018|
|0.1.0||Mar 24, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.19.0 <2.0.0|