pubspec 0.0.15

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 79

pubspec

A library for manipulating pubspec files.

Usage

A simple usage example:

import 'package:pubspec/pubspec.dart';

main() {
  // load it
  var pubSpec = await PubSpec.load(myDirectory);

  // change the dependencies to a single path dependency on project 'foo'
  var newPubSpec = pubSpec.copy(dependencies: { 'foo': new PathReference('../foo') });

  // save it
  await newPubSpec.save(myDirectory);
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.11

  • additional constructor

0.0.10

  • tidied a few things

0.0.9

  • Bug Fix. publish_to was serialising to publishTo

0.0.8

  • upgraded some dependencies

0.0.7

  • add publish_to

0.0.6

  • tidy dependencies

0.0.3

  • Added property allDependencies which combines dependencies with devDependencies

0.0.2

  • Added == and hashCode to dependency reference classes

0.0.1

  • Initial version, created by Stagehand

example/pubspec.dart

// Copyright (c) 2015, Anders Holmgren. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library pubspec.example;

main() {}

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pubspec: "^0.0.15"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pubspec/pubspec.dart';
        
Version Uploaded Documentation Archive
0.0.15 Jan 29, 2018 Go to the documentation of pubspec 0.0.15 Download pubspec 0.0.15 archive
0.0.14 Jun 25, 2016 Go to the documentation of pubspec 0.0.14 Download pubspec 0.0.14 archive
0.0.13 Apr 4, 2016 Go to the documentation of pubspec 0.0.13 Download pubspec 0.0.13 archive
0.0.12 Apr 2, 2016 Go to the documentation of pubspec 0.0.12 Download pubspec 0.0.12 archive
0.0.11 Mar 26, 2016 Go to the documentation of pubspec 0.0.11 Download pubspec 0.0.11 archive
0.0.10 Mar 25, 2016 Go to the documentation of pubspec 0.0.10 Download pubspec 0.0.10 archive
0.0.9 Jan 24, 2016 Go to the documentation of pubspec 0.0.9 Download pubspec 0.0.9 archive
0.0.8 Jan 23, 2016 Go to the documentation of pubspec 0.0.8 Download pubspec 0.0.8 archive
0.0.7 Jan 21, 2016 Go to the documentation of pubspec 0.0.7 Download pubspec 0.0.7 archive
0.0.6 Jan 21, 2016 Go to the documentation of pubspec 0.0.6 Download pubspec 0.0.6 archive

All 19 versions...

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
60 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
79
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:pubspec/pubspec.dart with components: io.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 5 hints.

    Run dartfmt to format lib/src/dependency.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0
path ^1.3.9 1.3.9 1.5.1
pub_semver ^1.2.3 1.3.5
stuff ^0.0.7 0.0.7
yaml ^2.1.8 2.1.13
yamlicious ^0.0.4 0.0.5
Transitive dependencies
charcode 1.1.1
collection 1.14.9
concepts 0.2.0
either 0.1.8
matcher 0.12.1+4
meta 1.1.2
option 1.2.0
quiver 0.21.4 0.29.0+1
quiver_iterables 1.0.1
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
uri 0.11.2
utf 0.9.0+4
Dev dependencies
test ^0.12.7