pubspec_parse 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new50

Build Status

Supports parsing pubspec.yaml files with robust error reporting and support for most of the documented features.

Read more about the pubspec format.

Features and bugs

Please file feature requests and bugs at the issue tracker.

0.1.2

  • Allow superfluous version keys with git and path dependencies.
  • Improve errors when unsupported keys are provided in dependencies.
  • Provide better errors with invalid sdk dependency values.
  • Support "scp-like syntax" for Git SSH URIs in the form [user@]host.xz:path/to/repo.git/.

0.1.1

  • Fixed name collision with error type in latest package:json_annotation.
  • Improved parsing of hosted dependencies and environment constraints.

0.1.0

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pubspec_parse: "^0.1.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:pubspec_parse/pubspec_parse.dart';
  
Version Uploaded Documentation Archive
0.1.2 Jun 20, 2018 Go to the documentation of pubspec_parse 0.1.2 Download pubspec_parse 0.1.2 archive
0.1.1 Jun 8, 2018 Go to the documentation of pubspec_parse 0.1.1 Download pubspec_parse 0.1.1 archive
0.1.0 Jun 4, 2018 Go to the documentation of pubspec_parse 0.1.0 Download pubspec_parse 0.1.0 archive

Analysis

We analyzed this package on Jun 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
50
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:pubspec_parse/pubspec_parse.dart.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use pubspec_parse.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.54 <2.0.0
json_annotation ^0.2.8 0.2.8
pub_semver ^1.3.2 1.4.1
yaml ^2.1.12 2.1.14
Transitive dependencies
charcode 1.1.1
collection 1.14.10
source_span 1.4.0
string_scanner 1.0.2
Dev dependencies
build_runner ^0.8.0
json_serializable ^0.5.7
path ^1.5.1 1.6.1
stack_trace ^1.9.2
test ^0.12.42
test_descriptor ^1.0.3
test_process ^1.0.2