pubviz 2.4.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 74

Visualize package dependencies in your Dart project

Build Status Coverage Status

Make sure you run pub get or pub upgrade in your target project directory.

Example

Here's an example of pubviz run on itself.

Installing

Activate pubviz.

~/anypath/> pub global activate pubviz

Use

If you have installed Dart v1.7+ and modified your PATH, you can run pubviz directly.

~/proj_path/> pubviz [arguments]

Otherwise you can use the pub global command.

~/proj_path/> pub global run pubviz [arguments]

Generate and open an html file for the package on the current path.

~/http_package/> pubviz open

Should open your default browser to something like:

sample

~/any_path/> pubviz --format=dot print /path/to/http_package

You should see output something like:

digraph G {
  node [fontname=Helvetica];
  edge [fontname=Helvetica, fontcolor=gray];

  http [label="http
0.9.2+3",fontsize=18,style=bold,shape=box,margin="0.25,0.15"];
  http -> path [label=">=0.9.0 <2.0.0",penwidth=2];
  http -> stack_trace [label=">=0.9.1 <0.10.0",penwidth=2];
  http -> unittest [label=">=0.9.0 <0.10.0",penwidth=2,style=dashed];

  path [label="path
1.0.0",shape=box,margin="0.25,0.15",style=bold];

  stack_trace [label="stack_trace
0.9.1",shape=box,margin="0.25,0.15",style=bold];
  stack_trace -> path [label=">=1.0.0-rc.1 <2.0.0"];

  unittest [label="unittest
0.9.3",style=bold];
  unittest -> stack_trace [label=">=0.9.0 <0.10.0",color=gray];
}

pubviz with no arguments prints help

usage: pubviz [--format=<format>] (open | print) [<package path>]

  open   Populate a temporary file with the content and open it.
  print  Print the output to stdout.

-f, --format
          [dot]             Generate a GraphViz dot file
          [html]            Wrap the GraphViz dot format in an HTML template which renders it.

-o, --[no-]flag-outdated    Check pub.dartlang.org for lasted packages and flag those that are outdated.

If <package path> is omitted, the current directory is used.

2.4.2

  • Updated output format.

  • And other cleanup...

2.4.1

  • Using nodesep=0.2 on the graph to make it tighter.

  • Hosted code

    • Much more robust handling of node clicks to add/remove.

    • Make it clear that nodes can be clicked by changing the cursor.

2.4.0

  • Better error output if a subprocess fails.

  • Try to handle flutter packages.

2.3.11

  • Better hover-over behavior for outdated dependencies.

2.3.10

  • Update gviz.

  • Support larger dependency graphs.

  • Update version of viz.js.

  • Use viz-lite.js – smaller download.

    • Continue to host vis.js so we don't break existing installations.

2.3.9+1

  • Use gviz package. Get out of the GraphViz formatting business.

2.3.9

  • Updated dependencies.

  • Fix case where we're pulling in a pre-release version that is after the latest stable version.

2.3.8

  • Send a descriptive user agent to the server.

  • Added retry logic for HTTP requests.

  • Sort the output.

2.3.7

  • Better stack trace on errors.

2.3.6

  • Cleanup, handled some deprecations, improve load time.

2.3.5

  • Tweaks test code, examples, dependencies.

2.3.4

  • Properly escape the latest version for outdated dependencies.

  • Add a reasonable tool-tip for the entire graph.

  • Don't show the root node as outdated.

2.3.3

  • Using CSS animations for effects. Hosting style on GitHub.

2.3.2

  • All fancy with mouse-over effects.

2.3.1+1

  • Fix README.md.

2.3.1

  • With --flag-outdated (-o) do version lookup in parallel. MUCH faster.

2.3.0

  • Allow ignoring packages via --ignore-packages. Thanks, Günter!

  • A fix for running on Windows. Thanks, Oliver!

  • A fix for formatting packages with hyphens. Thanks, Bryon!

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pubviz: "^2.4.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pubviz/pubviz.dart';
        
Version Uploaded Documentation Archive
2.4.2 Dec 27, 2017 Go to the documentation of pubviz 2.4.2 Download pubviz 2.4.2 archive
2.4.1 Dec 21, 2017 Go to the documentation of pubviz 2.4.1 Download pubviz 2.4.1 archive
2.4.0 Nov 28, 2017 Go to the documentation of pubviz 2.4.0 Download pubviz 2.4.0 archive
2.3.11 Aug 16, 2017 Go to the documentation of pubviz 2.3.11 Download pubviz 2.3.11 archive
2.3.10 Aug 16, 2017 Go to the documentation of pubviz 2.3.10 Download pubviz 2.3.10 archive
2.3.9+1 Aug 3, 2017 Go to the documentation of pubviz 2.3.9+1 Download pubviz 2.3.9+1 archive
2.3.9 Jul 7, 2017 Go to the documentation of pubviz 2.3.9 Download pubviz 2.3.9 archive
2.3.8 May 19, 2017 Go to the documentation of pubviz 2.3.8 Download pubviz 2.3.8 archive
2.3.7 Sep 20, 2016 Go to the documentation of pubviz 2.3.7 Download pubviz 2.3.7 archive
2.3.6 Feb 11, 2016 Go to the documentation of pubviz 2.3.6 Download pubviz 2.3.6 archive

All 33 versions...

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
48 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
74

Platforms

Detected platforms: Flutter, other

Primary library: package:pubviz/pubviz.dart with components: io.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use pubviz.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0
args >=0.13.0 <2.0.0 1.3.0
collection ^1.0.0 1.14.5
gviz ^0.2.0 0.2.0
http ^0.11.1+3 0.11.3+16
path ^1.0.0 1.5.1
pub_semver ^1.0.0 1.3.2
stack_trace ^1.6.0 1.9.1
yaml ^2.0.0 2.1.13
Transitive dependencies
async 2.0.3
charcode 1.1.1
http_parser 3.1.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
js ^0.6.1
test ^0.12.0