punycode 0.0.1

  • README.md
  • Example
  • Installing
  • Versions
  • 0


Direct translation of the C algorithm in RFC 3492 to dart.

Stringprep / PRECIS

This library does not implement stringprep (RFC 3454) or PRECIS (RFC 7564).

Those RFCs are needed for domain name conversion.



  • Initial version, created by Stagehand


// Copyright (c) 2017, cl. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:punycode/punycode.dart';

void main() {
  const unicode = 'B├╝cher';
  var encoded = punycodeEncode(unicode);
  print('$unicode encoded is $encoded');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  punycode: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:punycode/punycode.dart';
Version Uploaded Documentation Archive
0.0.1 Jun 29, 2017 Go to the documentation of punycode 0.0.1 Download punycode 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0