pure_mixpanel 1.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 31

pure_mixpanel

A pure Dart library for Mixpanel analytics.

Running Tests

This library has Flutter as a dependency for easier testability. The tests are true end to end tests, using a real Mixpanel account and API token that anyone is free to use. I decided against mocking the API for now to keep the codebase simple.

flutter test test/pure_mixpanel_test.dart

Features

  • Event tracking

Upcoming Features

[1.0.2] - 7/9/18

  • Fix for siutations where debug flag isn't passed in constructor.

[1.0.1] - 7/8/18

  • Minor tweaks.

[1.0.0] - 7/7/18

  • Initial release, supporting Mixpanel event tracking.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pure_mixpanel: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pure_mixpanel/pure_mixpanel.dart';
  
Version Uploaded Documentation Archive
1.0.2 Jul 9, 2018 Go to the documentation of pure_mixpanel 1.0.2 Download pure_mixpanel 1.0.2 archive
1.0.1 Jul 7, 2018 Go to the documentation of pure_mixpanel 1.0.1 Download pure_mixpanel 1.0.1 archive
1.0.0 Jul 7, 2018 Go to the documentation of pure_mixpanel 1.0.0 Download pure_mixpanel 1.0.0 archive
0.0.1 Jul 7, 2018 Go to the documentation of pure_mixpanel 0.0.1 Download pure_mixpanel 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
31
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0