pusher_js 1.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 6

pusher

A Dart wrapper for Pusher.js

Usage

import 'package:pusher_js/pusher_js.dart';

main() {
  var socket = new Pusher('0eb73a235dd03b3df71a');
  socket.connection.bind('connected', allowInterop((data) {
    print('Connected to Pusher!');
  }));
}

Note: callbacks should be wrapped in allowInterop().

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

1.0.0

  • Initial version

1.0.1

  • rename to pusher_js

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pusher_js: ^1.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pusher_js/pusher_js.dart';
  
Version Uploaded Documentation Archive
1.2.0 Aug 16, 2017 Go to the documentation of pusher_js 1.2.0 Download pusher_js 1.2.0 archive
1.1.0 Aug 12, 2016 Go to the documentation of pusher_js 1.1.0 Download pusher_js 1.1.0 archive
1.0.2 Aug 10, 2016 Go to the documentation of pusher_js 1.0.2 Download pusher_js 1.0.2 archive
1.0.1 Aug 10, 2016 Go to the documentation of pusher_js 1.0.1 Download pusher_js 1.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
12
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0