qr_flutter 1.1.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 97

QR.Flutter is a Flutter library for simple and fast QR code rendering via a Widget or custom painter.

Features

  • Built on QR - Dart
  • Supports QR code versions 1 - 40
  • Error correction / redundancy
  • Configurable output size, padding, background and foreground colors
  • No internet connection required

Installing

You can install the package by adding the following lines to your pubspec.yaml:

dependencies:
  qr_flutter: ^1.1.3

After adding the dependency to your pubspec.yaml you can run: flutter packages get or update your packages using your IDE.

Getting started

To start, import the dependency in your code:

import 'package:qr_flutter/qr_flutter.dart';

Next, to render a basic QR code you can use the following code (or something like it):

new QrImage(
  data: "1234567890",
  size: 200.0,
),

Depending on your data requirements you may want to tweak the QR code output. The following options are available:

PropertyTypeDescription
versionintA value between 1 and 40. See http://www.qrcode.com/en/about/version.html for details.
errorCorrectionLevelintA value defined on QrErrorCorrectLevel. e.g.: QrErrorCorrectLevel.L.
sizedoubleThe (square) size of the image. If not given, will auto size using shortest size constraint.
paddingEdgeInsetsPadding surrounding the QR code data
backgroundColorColorThe background color (default is none)
foregroundColorColorThe foreground color (default is black)

Example

See the example directory for a basic working example.

FAQ

Has it been tested in production? Can I use it in production?

Yep! It's stable and ready to rock. It's currently in use in quite a few production applications including:

Outro

Credits

Thanks to Kevin Moore for his awesome QR - Dart library. It's the core of this library.

For author/contributor information, see the AUTHORS file.

License

QR.Flutter is released under a modified MIT license. See LICENSE for details.

1.1.3

  • Lower min sdk version to cater to some older versions of Flutter

1.1.2

  • The QrImage widget will now autosize if no size has been defined (thanks @romkor!)
  • Requires Dart 2 (as so does Flutter)
  • Dart 2 pubspec compatability changes

1.1.1

  • Fixes and issue where the QR image won't get repainted even though the data has changed

1.1.0

  • Update to 1.0 release of the dart qr library

1.0.0

  • Initial release

example/lib/main.dart

import 'package:flutter/material.dart';

import 'screens/main.screen.dart';

void main() => runApp(new App());

class App extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'QR code demo',
      theme: new ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: new MainScreen(),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  qr_flutter: ^1.1.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:qr_flutter/qr_flutter.dart';
  
Version Uploaded Documentation Archive
1.1.3 Aug 9, 2018 Go to the documentation of qr_flutter 1.1.3 Download qr_flutter 1.1.3 archive
1.1.2 Aug 6, 2018 Go to the documentation of qr_flutter 1.1.2 Download qr_flutter 1.1.2 archive
1.1.1 Apr 20, 2018 Go to the documentation of qr_flutter 1.1.1 Download qr_flutter 1.1.1 archive
1.1.0 Apr 20, 2018 Go to the documentation of qr_flutter 1.1.0 Download qr_flutter 1.1.0 archive
1.0.0 Mar 4, 2018 Go to the documentation of qr_flutter 1.0.0 Download qr_flutter 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
94
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
97
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3
  • Flutter: 0.8.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.58.0 <3.0.0
flutter 0.0.0
qr ^1.0.0 1.0.1
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8