quagga_dart 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 43

quagga_dart

Port of QuaggaJs library. QuaggaJS is a barcode-scanner entirely written in JavaScript supporting real- time localization and decoding of various types of barcodes such as EAN, CODE 128, CODE 39, EAN 8, UPC-A, UPC-C, I2of5 and CODABAR.

Usage

A simple usage example:

index.html

<script src="packages/quagga_dart/js/dist/quagga.js"></script>

<div class="viewport" id="interactive"></div>

main.dart

import 'package:quagga_dart/quagga_dart.dart' as quagga;

main() {
      quagga.Constraints constraints = new quagga.Constraints(width: 640, height: 480);
      quagga.InputStream inputStream = new quagga.InputStream(type: "LiveStream", constraints: constraints);
      quagga.Locator locator = new quagga.Locator(patchSize: "medium", halfSample: false);
      quagga.Decoder decoder = new quagga.Decoder(readers: ["code_128_reader"]);
  
      quagga.InitOption option = new quagga.InitOption(
          inputStream: inputStream, locator: locator, numOfWorkers: 0, locate: true, tracking: true, decoder: decoder);
  
      quagga.init(option, allowInteropCaptureThis((quagga.Error err) {
        if (err != null && err.message != null) {
          return;
        }
        quagga.start();
      }));
  
      quagga.onDetected(allowInterop((quagga.ResultData data) {
        print(data);
        quagga.stop();
      }));
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

example/quagga_dart.dart

// Copyright (c) 2015, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library quagga_dart.example;

import 'package:quagga_dart/quagga_dart.dart';
import 'package:js/js.dart';


main() {

}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  quagga_dart: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:quagga_dart/quagga_dart.dart';
  
Version Uploaded Documentation Archive
0.0.2 May 11, 2016 Go to the documentation of quagga_dart 0.0.2 Download quagga_dart 0.0.2 archive
0.0.1 Dec 12, 2015 Go to the documentation of quagga_dart 0.0.1 Download quagga_dart 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7

Platforms

Detected platforms: web, other

Primary library: package:quagga_dart/quagga_dart.dart with components: js.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Package is too old.

The package was released more than two years ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Format lib/quagga_dart.dart.

Run dartfmt to format lib/quagga_dart.dart.

Format lib/src/decode_option.dart.

Run dartfmt to format lib/src/decode_option.dart.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/decoder.dart (Run dartfmt to format lib/src/decoder.dart.)
  • lib/src/init_option.dart (Run dartfmt to format lib/src/init_option.dart.)
  • lib/src/locator.dart (Run dartfmt to format lib/src/locator.dart.)
  • lib/src/result_data.dart (Run dartfmt to format lib/src/result_data.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0
js ^0.6.0 0.6.1+1
Dev dependencies
test >=0.12.0 <0.13.0