quartet 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new46

This library is still largely WIP, check back when we are hit v0.1.0! :)

Quartet.dart

Your ultimate string instruments in Dart.

Introduction

Quartet is a huge collection of useful string manipulation functions written in the Dart language.

Features

Case conversion, slicing and chopping, escaping, querying and more.

0.0.1

  • Initial release.
  • Complete case functions.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  quartet: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:quartet/quartet.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 1, 2018 Go to the documentation of quartet 0.0.1 Download quartet 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:quartet/quartet.dart.

Health suggestions

Fix lib/src/quartet.dart. (-0.50 points)

Analysis of lib/src/quartet.dart reported 1 hint:

line 1 col 8: Unused import: './case/capitalize.dart'.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use quartet.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
test ^1.0.0