query_builder_sql 0.0.0

  • README.md
  • Installing
  • Versions
  • 40

query_builder_sql

version 1.0.0-alpha build status

Common functionality for SQL database use with package:query_builder.

This package, in most cases, will not be used directly. package:query_builder_postgres and similar packages build on top of this package to create and execute safe SQL queries through a fluent, familiar API.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  query_builder_sql: ^0.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:query_builder_sql/query_builder_sql.dart';
  
Version Uploaded Documentation Archive
0.0.0 Jun 17, 2017 Go to the documentation of query_builder_sql 0.0.0 Download query_builder_sql 0.0.0 archive
1.0.0-alpha Jun 11, 2017 Go to the documentation of query_builder_sql 1.0.0-alpha Download query_builder_sql 1.0.0-alpha archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
53
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Aug 16, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because query_builder_sql depends on query_builder >=0.0.1 which requires SDK version >=1.19.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Package is getting outdated.

The package was released 60 weeks ago.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use query_builder_sql.dart.

Format lib/query_builder_sql.dart.

Run dartfmt to format lib/query_builder_sql.dart.

Format lib/src/abstract.dart.

Run dartfmt to format lib/src/abstract.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0