query_params 0.6.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 78

query_params

A flutter package to create URL query parameters.

Getting Started

Add this to your package's pubspec.yaml file:

query_params: '^0.6.1'

Install packages:

with pub:

$ pub get

or with Flutter:

$ flutter packages get

Import it:

import 'package:query_params/query_params.dart';

Implement it:

URLQueryParams queryParams = new URLQueryParams();

queryParams.append('value1',"1");
queryParams.append('value2',"myString");

print(queryParams.toString()); // value1=1&value2=myString

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  query_params: ^0.6.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:query_params/query_params.dart';
  
Version Uploaded Documentation Archive
0.6.1 Sep 16, 2018 Go to the documentation of query_params 0.6.1 Download query_params 0.6.1 archive
0.6.0 Sep 16, 2018 Go to the documentation of query_params 0.6.0 Download query_params 0.6.0 archive
0.5.0 Jun 11, 2018 Go to the documentation of query_params 0.5.0 Download query_params 0.5.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-10 points)

4 out of 4 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use query_params.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test