query_string 1.0.4

  • README.md
  • Installing
  • Versions
  • 50

QueryString

This is a query string parser. It turns those nasty query strings into Dart Maps.

Examples

import 'package:query_string/query_string.dart';

void main() {
  var q = '?page=main&action=front&sid=h985jg9034gj498g859gh495&enc=+Hello%20&empty';
  
  var r = QueryString.parse(q);
  
  print(r['page']); // "main"
  print(r['asdasd']); // null
}

Installation

Until pub is open to public submissions, you have to specify the path to this Git repository in your pubspec.yaml:

dependencies:
  query_string:
  	git: https://github.com/kaisellgren/QueryString.git

License

This library is licensed under MIT.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  query_string: "^1.0.4"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:query_string/query_string.dart';
        
Version Uploaded Documentation Archive
1.0.4 Feb 14, 2014 Go to the documentation of query_string 1.0.4 Download query_string 1.0.4 archive
1.0.3 Nov 13, 2013 Go to the documentation of query_string 1.0.3 Download query_string 1.0.3 archive
1.0.2 Jun 24, 2013 Go to the documentation of query_string 1.0.2 Download query_string 1.0.2 archive
1.0.1 Dec 11, 2012 failed Download query_string 1.0.1 archive
1.0.0 Oct 29, 2012 failed Download query_string 1.0.0 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
45 / 100
Health:
Code health derived from static analysis. [more]
92 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
50
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:query_string/query_string.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use query_string.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 hint.

    Run dartfmt to format lib/query_string.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=0.8.10+6 <2.0.0
Dev dependencies
unittest >=0.9.0 <0.10.0