quiver_hashcode 2.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 84

Quiver Hashcode

Build Status Coverage Status

Documentation

API Docs

Contains functions hashObjects, hash2, hash3, and hash4 that generate high-quality hashCodes for a list of objects, or 2, 3, or 4 arguments respectively.

2.0.0

  • Declare support for Dart 2, drop support for Dart 1.

1.0.0-dev.1

  • Split from Quiver

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  quiver_hashcode: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:quiver_hashcode/hashcode.dart';
  
Version Uploaded Documentation Archive
2.0.0 Aug 17, 2018 Go to the documentation of quiver_hashcode 2.0.0 Download quiver_hashcode 2.0.0 archive
1.0.0 Jan 13, 2016 Go to the documentation of quiver_hashcode 1.0.0 Download quiver_hashcode 1.0.0 archive
1.0.0-dev.1 Nov 18, 2015 Go to the documentation of quiver_hashcode 1.0.0-dev.1 Download quiver_hashcode 1.0.0-dev.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
80
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use quiver_hashcode.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.61 <3.0.0
Dev dependencies
test ^1.0.0