quiver_iterables 1.0.1

  • README.md
  • Installing
  • Versions
  • 7

Quiver Iterables

A collection of utilities for generating and manipulating Dart Iterables.

Build Status Coverage Status


API Docs

concat, count, cycle, enumerate, merge, partition, range, and zip create, transform, or combine Iterables in different ways, similar to Python's itertools.

min, max, and extent retrieve the minimum and maximum elements from an iterable.

GeneratingIterable is an easy way to create lazy iterables that produce elements by calling a function. A common use-case is to traverse properties in an object graph, like the parent relationship in a tree.

InfiniteIterable is a base class for Iterables that throws on operations that require a finite length.

1.0.1 - 2017-09-07

  • Apply function generics across the package. From @jackd.
  • Add @alwaysThrows annotations where applicable. From @jackd.

1.0.0+1 - 2017-09-07

  • Strong-mode fix in InfiniteIterable.fold(), from @giorgiofran.


  • Split from quiver-dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  quiver_iterables: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:quiver_iterables/iterables.dart';
Version Uploaded Documentation Archive
1.0.1 Sep 7, 2017 Go to the documentation of quiver_iterables 1.0.1 Download quiver_iterables 1.0.1 archive
1.0.0+1 Sep 7, 2017 Go to the documentation of quiver_iterables 1.0.0+1 Download quiver_iterables 1.0.0+1 archive
1.0.0 Jan 13, 2016 Go to the documentation of quiver_iterables 1.0.0 Download quiver_iterables 1.0.0 archive
1.0.0-dev.1 Nov 18, 2015 Go to the documentation of quiver_iterables 1.0.0-dev.1 Download quiver_iterables 1.0.0-dev.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0 <2.0.0