rainbow_vis 0.0.1

  • README.md
  • Installing
  • Versions
  • 0

rainbowvis-dart

Pub Travis

Color data visualization; easily map numbers to a smooth-transitioning color legend. This is a port of the RainbowVis-JS written by anomal.

Usage

Instantiate a Rainbow, e.g.

  Rainbow rb0 = new Rainbow(); //[0,100],red-yellow-green-blue
  Rainbow rb1 = new Rainbow(minNum:-10, maxNum: 10); 
  Rainbow rb2 = new Rainbow.fromArray(['red', 'FFFFFF', '#00ff00']);
  Rainbow rb3 = new Rainbow.fromArray(['red', 'blue'], minNum: -0.5, maxNum: 0.5);

To interpolate a color among the spectrum, use the list access operator, e.g.

  Rainbow rb0 = new Rainbow(minNum:-10, maxNum: 10); 
  var myColdColor = rb0[-9.32];
  var myWarmCOlor = rb0[8.44];

Testing

To run on vm (default): pub run test As usual, tests can be run on other platforms with -p<platform>

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rainbow_vis: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rainbow_vis/rainbow_vis.dart';
  
Version Uploaded Documentation Archive
0.0.1 Sep 3, 2016 Go to the documentation of rainbow_vis 0.0.1 Download rainbow_vis 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0