random_string 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 42

random_string

Simple library for generating random ascii strings.

Usage

A simple usage example:

import 'package:random_string/random_string.dart' as random;

main() {
  print(randomBetween(10,20)); // some integer between 10 and 20
  print(randomNumeric(4)); // sequence of 4 random numbers i.e. 3259
  print(randomString(10)); // random sequence of 10 characters i.e. e~f93(4l-
  print(randomAlpha(5)); // random sequence of 5 alpha characters i.e. aRztC
  print(randomAlphaNumeric(10)); // random sequence of 10 alpha numeric i.e. aRztC1y32B
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand
  • Added randomBetween, randomString, randomNumeric, randomAlpha, randomAlphaNumeric, and randomMerge.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  random_string: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:random_string/random_string.dart';
  
Version Uploaded Documentation Archive
0.0.1 Apr 13, 2016 Go to the documentation of random_string 0.0.1 Download random_string 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
84
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
42
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0