random_users 0.0.3

  • README.md
  • Example
  • Installing
  • Versions
  • 0

Random Users Build Status

Just a static list of Random Users to be used for for all things pulled from https://randomuser.me/.


import 'package:random_users/random_users.dart';

// get the same 1000 users every time.
List<RandomUser> users = getUsers(1000);
print('Users: ${users.map((user) => user.firstName)}');

User data currently includes:

  • firstName
  • lastName
  • phoneNumber
  • userName
  • password
  • email
  • gender
  • largePicture
  • mediumPicture
  • thumbNail


Random Users leverages the dart_dev package for most of its tooling needs, including static analysis, code formatting, running tests, collecting coverage, and serving examples. Check out the dart_dev readme for more information.

Testing - pub run dart_dev test

Formatting - pub run dart_dev format



  • Adding a default constructor to RandomUser


  • Readme updates


  • Initial version, created by Stagehand.
  • Initial rollout with lists of users.


import 'package:random_users/random_users.dart';

main() {
  List<RandomUser> users = getUsers(1000);
  print('Users: ${users.map((user) => user.firstName)}');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  random_users: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:random_users/random_users.dart';
Version Uploaded Documentation Archive
0.0.3 Sep 23, 2016 Go to the documentation of random_users 0.0.3 Download random_users 0.0.3 archive
0.0.2 Sep 21, 2016 Go to the documentation of random_users 0.0.2 Download random_users 0.0.2 archive
0.0.1 Sep 21, 2016 Go to the documentation of random_users 0.0.1 Download random_users 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0