range_header 1.0.0

  • README.md
  • Installing
  • Versions
  • 46

range_header

version 1.0.0 build status coverage: 100%

Range header parser for Dart.

Usage

handleRequest(HttpRequest request) async {
  // Parse the header
  var header = parseRangeHeader(request.headers.value(HttpHeaders.RANGE));
  
  // Get info
  header.items;
  header.rangeUnit;
  header.toContentRange();
}

This package powers package:angel_range as well.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  range_header: "^1.0.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:range_header/range_header.dart';
        
Version Uploaded Documentation Archive
1.0.0 Jun 11, 2017 Go to the documentation of range_header 1.0.0 Download range_header 1.0.0 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
46

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:range_header/range_header.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use range_header.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
charcode ^1.0.0 1.1.1
string_scanner ^1.0.0 1.0.2
Transitive dependencies
path 1.5.1
source_span 1.4.0
Dev dependencies
test ^0.12.0