rapier 1.0.0-dev

  • README.md
  • Installing
  • Versions
  • 33

rapier

Dart Web automation framework.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rapier: ^1.0.0-dev

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rapier/browser.dart';
import 'package:rapier/common.dart';
import 'package:rapier/io.dart';
import 'package:rapier/runner.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev Nov 26, 2016 Go to the documentation of rapier 1.0.0-dev Download rapier 1.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
15
Overall:
Weighted score of the above. [more]
33
Learn more about scoring.

We analyzed this package on Aug 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because rapier depends on container >=0.1.1 which requires SDK version >=1.8.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed.

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Package is getting outdated.

The package was released 90 weeks ago.

Package is pre-release.

Pre-release versions should be used with caution, their API may change in breaking ways.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Format lib/common.dart.

Run dartfmt to format lib/common.dart.

Format lib/src/task_info.dart.

Run dartfmt to format lib/src/task_info.dart.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use rapier.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0