rapier 1.0.0-dev

  • README.md
  • Installing
  • Versions
  • 29


Dart Web automation framework.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  rapier: "^1.0.0-dev"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:rapier/browser.dart';

      import 'package:rapier/common.dart';

      import 'package:rapier/io.dart';

      import 'package:rapier/runner.dart';
Version Uploaded Documentation Archive
1.0.0-dev Nov 26, 2016 Go to the documentation of rapier 1.0.0-dev Download rapier 1.0.0-dev archive


We analyzed this package on Jun 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
79 / 100
Reflects how tidy and up-to-date the package is. [more]
30 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: web

Platform components identified in package: html, io, mirrors.


  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 3 errors 2 hints.

    Strong-mode analysis of lib/runner.dart failed with the following error:

    line: 60 col: 12
    The function expression type '(Task) → bool' isn't of type '(dynamic) → bool'. This means its parameter or return type does not match what is expected. Consider changing parameter type(s) or the returned type(s).

    Run dartfmt to format lib/common.dart.

    Similar analysis of the following files failed:

    • lib/src/task_info.dart (hint)
  • Package is getting outdated.

    The package was released 81 weeks ago.

  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use rapier.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
analyzer ^0.29.0 0.29.11 0.32.1
args ^0.13.7 0.13.7 1.4.3
container ^0.1.2 0.1.2
html ^0.13.0 0.13.3+1
http ^0.11.3+9 0.11.3+16
json_god ^2.0.0-beta 2.0.0-beta+2
Transitive dependencies
async 2.0.7
charcode 1.1.1
cli_util 0.0.1+2 0.1.3
collection 1.14.10
convert 2.0.1
crypto 2.0.5
csslib 0.14.4
dart2_constant 1.0.1+dart2
glob 1.1.6
http_parser 3.1.2
isolate 1.1.0 2.0.1
logging 0.11.3+1
meta 1.1.5
package_config 1.0.3
path 1.6.1
plugin 0.2.0+2
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+8
when 0.2.0
which 0.1.3
yaml 2.1.14
Dev dependencies
test ^0.12.16