raven_dart 0.1.1

  • README.md
  • Installing
  • Versions
  • 24

Basic Usage

import 'package:raven_dart/raven_dart.dart';

main() {
  var dsn    = 'https://b70a31b3510c4cf793964a185cfe1fd0:b7d80b520139450f903720eb7991bf3d@example.com/1';

  // initialize the client with your DSN
  var client = new RavenClient(dsn);

  // captures a message as an info event 
  client.captureMessage("test");

  try {
    throw new Exception("test exception");
  } catch (exn, stacktrace) {
	// captures exception with stacktrace as an error event
    client.captureException(exn, stacktrace);
  }
}

Resources

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  raven_dart: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:raven_dart/raven_dart.dart';
  
Version Uploaded Documentation Archive
0.1.1 Jul 5, 2014 Go to the documentation of raven_dart 0.1.1 Download raven_dart 0.1.1 archive
0.1.0 Jul 5, 2014 Go to the documentation of raven_dart 0.1.0 Download raven_dart 0.1.0 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
79 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
24
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:raven_dart/raven_dart.dart with components: io, isolate.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Package is too old.

    The package was released more than two years ago.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 5 errors 14 hints.

    Strong-mode analysis of lib/src/dsn.dart failed with the following error:

    line: 43 col: 46
    The argument type '(dynamic) → dynamic' can't be assigned to the parameter type '(String) → bool'.

    Strong-mode analysis of lib/src/http.dart failed with the following error:

    line: 92 col: 17
    The argument type '(Map<dynamic, dynamic>) → Null' can't be assigned to the parameter type '(dynamic) → void'.

    Similar analysis of the following files failed:

    • lib/src/message.dart (error)
    • lib/raven_dart.dart (hint)
    • lib/src/constants.dart (hint)
    • lib/src/enums.dart (hint)
    • lib/src/exceptions.dart (hint)
    • lib/src/scrubber.dart (hint)
    • lib/src/utils.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use raven_dart.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
http >=0.11.1+1 <0.12.0 0.11.3+16
uuid >=0.3.2 <0.4.0 0.3.2 1.0.0
Transitive dependencies
async 2.0.7
bignum 0.0.7 0.1.0
charcode 1.1.1
cipher 0.7.1
collection 1.14.10
convert 1.1.1 2.0.1
crypto 0.9.2+1 2.0.5
fixnum 0.9.1+2 0.10.7
http_parser 3.1.2
path 1.6.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
unittest any