recaptcha_facade 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

recaptcha_facade

Library to render and control recaptcha.

From authors of Jaguar.

Usage

import 'package:recaptcha_facade/recaptcha_facade.dart';

main() async {
  final recaptcha = await Recaptcha.create(
      '6Lf3HCkUAAAAAJ2mRonRdQ7Ma-k9Or9uj7lxRy7a', querySelector('#output'));
  recaptcha.onSuccess.listen(print);
}

Simple example

For a simple client-only example, check out this example.

Complete example

For a complete example with client, check out this example.

Changelog

1.0.0

  • Recaptcha to render and control a recaptcha.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  recaptcha_facade: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:recaptcha_facade/recaptcha_facade.dart';
  
Version Uploaded Documentation Archive
1.0.0 Jan 14, 2018 Go to the documentation of recaptcha_facade 1.0.0 Download recaptcha_facade 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0