recompose_dart 0.0.9

  • README.md
  • Installing
  • Versions
  • 0

Pub

recompose_dart

recompose_dart is a collection of utilities for writing functional react components in dart.

Inspired by recompose

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  recompose_dart: ^0.0.9

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:recompose_dart/recompose_dart.dart';
  
Version Uploaded Documentation Archive
0.0.9 Apr 30, 2017 Go to the documentation of recompose_dart 0.0.9 Download recompose_dart 0.0.9 archive
0.0.8 Apr 19, 2017 Go to the documentation of recompose_dart 0.0.8 Download recompose_dart 0.0.8 archive
0.0.7 Apr 19, 2017 Go to the documentation of recompose_dart 0.0.7 Download recompose_dart 0.0.7 archive
0.0.6 Apr 19, 2017 Go to the documentation of recompose_dart 0.0.6 Download recompose_dart 0.0.6 archive
0.0.5 Apr 18, 2017 Go to the documentation of recompose_dart 0.0.5 Download recompose_dart 0.0.5 archive
0.0.4 Apr 17, 2017 Go to the documentation of recompose_dart 0.0.4 Download recompose_dart 0.0.4 archive
0.0.3 Apr 16, 2017 Go to the documentation of recompose_dart 0.0.3 Download recompose_dart 0.0.3 archive
0.0.2 Apr 16, 2017 Go to the documentation of recompose_dart 0.0.2 Download recompose_dart 0.0.2 archive
0.0.1 Apr 16, 2017 Go to the documentation of recompose_dart 0.0.1 Download recompose_dart 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.1 <2.0.0