A command line tool that uses the Reddit API to track popularity of a keyword. The tool is currently focused on tracking developer technologies, such as programming languages, frameworks or IDEs.
pub global activate reddit_crawl.
To get data for "dart" for the past 3 months (default), run this:
$ reddit_crawl dart
This will fetch the data and it will create 2 sets of files in the current working directory:
The JSON files include all the data received from Reddit API. The TSV file is useful for copypasting into spreadsheets and includes only a subset of the data and some helper columns.
Run the tool without parameters to get help.
$ reddit_crawl Exactly one argument is requred: a name of a technology. Additional options: -v, --verbose Verbose mode. --months Number of months to crawl in reverse chronological order. (defaults to "3") --mobile Use additional subreddits that specialize in mobile development. --web Use additional subreddits that specialize in web development.
To get all mentions of "vim" on major Reddit programming forums, including mobile- and web-focused ones, from the past 6 years (6 * 12 = 72 months), use:
$ reddit_crawl --months 72 --mobile --web vim
Later, you can just run
reddit_crawl --mobile --web vim to update your
output-vim-all files with the latest submissions.
You can install the package from the command line:
$ pub global activate reddit_crawl
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: reddit_crawl: ^0.0.2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:reddit_crawl/config.dart'; import 'package:reddit_crawl/json2csv.dart';
|0.0.2||May 26, 2017|
|0.0.1||May 26, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.23.0 <2.0.0|