redstone_spa_plugin 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 35

redstone_spa_plugin

A library for Dart developers. It is awesome.

Usage

A simple usage example:

import 'package:redstone_spa_plugin/redstone_spa_plugin.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  redstone_spa_plugin: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:redstone_spa_plugin/redstone_spa_plugin.dart';
        
Version Uploaded Documentation Archive
0.0.1 Jul 19, 2016 Go to the documentation of redstone_spa_plugin 0.0.1 Download redstone_spa_plugin 0.0.1 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
93 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
34 / 100
Overall score:
Weighted score of the above. [more]
35

Platforms

Detected platforms: unsure

Error(s) prevent platform classification.

Suggestions

  • Fix dependencies in pubspec.yaml.

    Running pub upgrade failed with the following output:

    ERR: Git error. Command: git clone --mirror git@github.com:redstone-dart/redstone.git /root/.pub-cache/git/cache/redstone-fafeff62cc338a32c85b8bf24f5ea77aba5dcc39
     Cloning into bare repository '/root/.pub-cache/git/cache/redstone-fafeff62cc338a32c85b8bf24f5ea77aba5dcc39'...
     Host key verification failed.
     fatal: Could not read from remote repository.
     
     Please make sure you have the correct access rights
     and the repository exists.
    
  • Fix platform conflicts.

    Make sure none of the libraries use mutually exclusive dependendencies.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0