redux_watch 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

redux_watch

Redux Watch to dart.

Used when you want to be notified that an particular state changed in the redux store.

Usage

A simple usage example:

// Create the watch by passing the store and a selector.
var watch =  new  ReduxWatch<AppState, int>(store, (state) => state.todosId);

// Now you can create how many listeners you need.
// Everytime the selector changes by a redux dispatch, the listeners will be called.
watch.listen((int oldValue, int newValue) => print('$oldValue -> $newValue'));
watch.listen((int oldValue, int newValue) => print('Hello World'));

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  redux_watch: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:redux_watch/redux_watch.dart';
  
Version Uploaded Documentation Archive
0.2.0 Apr 23, 2018 Go to the documentation of redux_watch 0.2.0 Download redux_watch 0.2.0 archive
0.1.2 Apr 23, 2018 Go to the documentation of redux_watch 0.1.2 Download redux_watch 0.1.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0