reflective 0.1.3

  • readme.md
  • Installing
  • Versions
  • 19

Dart Reflective #

Build Status

Reflective is fluent reflection API for Dart.

Examples:

TypeReflection typeOfEmployeeName = type(Employee).field('name').type;

Employee employee = type(Employee).construct(
    name: 'John Doe', 
    email: 'john@doe.org');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  reflective: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:reflective/reflective.dart';
  
Version Uploaded Documentation Archive
0.1.3 Apr 16, 2019 Go to the documentation of reflective 0.1.3 Download reflective 0.1.3 archive
0.1.2 Mar 26, 2019 Go to the documentation of reflective 0.1.2 Download reflective 0.1.2 archive
0.1.1 Dec 5, 2018 Go to the documentation of reflective 0.1.1 Download reflective 0.1.1 archive
0.1.0 Dec 5, 2018 Go to the documentation of reflective 0.1.0 Download reflective 0.1.0 archive
0.0.29 Jul 25, 2016 Go to the documentation of reflective 0.0.29 Download reflective 0.0.29 archive
0.0.28 May 30, 2016 Go to the documentation of reflective 0.0.28 Download reflective 0.0.28 archive
0.0.27 May 30, 2016 Go to the documentation of reflective 0.0.27 Download reflective 0.0.27 archive
0.0.26 Mar 27, 2016 Go to the documentation of reflective 0.0.26 Download reflective 0.0.26 archive
0.0.25 Mar 26, 2016 Go to the documentation of reflective 0.0.25 Download reflective 0.0.25 archive
0.0.24 Dec 14, 2015 Go to the documentation of reflective 0.0.24 Download reflective 0.0.24 archive

All 33 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
37
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
19
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <=3.0.0