reflutter_generator 0.3.0+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Reflutter

Status
CI BuildTravis
ReleaseTravis
PackagePub

Reflutter is a simple Dart library for automatically generating HTTP clients from simple metadata. It borrows heavily from the jaguar_http project and the Refit project for .NET.

Usage

See the example folder for a simple usage example.

Features and bugs

Please file bugs and feature requests on GitHub.

Changelog

0.3.0

  • Reorganized into three separate packages. reflutter will serve as the main dependency while refluter_generator can be a dev dependency.
  • Removed the dependency on the Jaguar project for serialization. Instead, we opt for the more standard Dart JSON serialization.
  • Test infrastructure and some very simple unit tests have been added.
  • Travis build infrastructure updated.

0.2.4

0.2.3

  • Build change to cache items between phases.

0.2.2

  • Initial release with a changelog.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  reflutter_generator: ^0.3.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:reflutter_generator/reflutter_generator.dart';
  
Version Uploaded Documentation Archive
0.3.0+1 Jul 8, 2018 Go to the documentation of reflutter_generator 0.3.0+1 Download reflutter_generator 0.3.0+1 archive
0.3.0 Jul 8, 2018 Go to the documentation of reflutter_generator 0.3.0 Download reflutter_generator 0.3.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.63.0 <2.0.0