refresh_to8toflutter_com 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new43

refresh_to8toflutter_com

刷新组件

Getting Started

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  refresh_to8toflutter_com: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:refresh_to8toflutter_com/behavior/behavior.dart';
import 'package:refresh_to8toflutter_com/footer/footer.dart';
import 'package:refresh_to8toflutter_com/header/header.dart';
import 'package:refresh_to8toflutter_com/refresher.dart';
import 'package:refresh_to8toflutter_com/refresh_safe_area.dart';
import 'package:refresh_to8toflutter_com/scrollPhysics/scroll_physics.dart';
  
Version Uploaded Documentation Archive
0.0.1 Jan 9, 2019 Go to the documentation of refresh_to8toflutter_com 0.0.1 Download refresh_to8toflutter_com 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
12
Health:
Code health derived from static analysis. [more]
82
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/footer/footer.dart. (-9.54 points)

Analysis of lib/footer/footer.dart reported 20 hints, including:

line 55 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 60 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 65 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 70 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 75 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/header/header.dart. (-8.17 points)

Analysis of lib/header/header.dart reported 17 hints, including:

line 54 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 59 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 64 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 69 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 74 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/scrollPhysics/scroll_physics.dart. (-1 points)

Analysis of lib/scrollPhysics/scroll_physics.dart reported 2 hints:

line 5 col 9: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 6 col 9: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/behavior/behavior.dart (Run flutter format to format lib/behavior/behavior.dart.)
  • lib/refresh_safe_area.dart (Run flutter format to format lib/refresh_safe_area.dart.)
  • lib/refresher.dart (Run flutter format to format lib/refresher.dart.)

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use refresh_to8toflutter_com.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test