replace_env_vars 0.1.0

  • Installing
  • Versions
  • 0

replace_env_vars #

Provides a transformer that can insert environment variable values into Dart files.

Usage #

Add as a dependency and as a transformer to your pubspec.yaml:

  replace_env_vars: ^0.1.0
- replace_env_vars

In your Dart code, you can mark an area for replacement by wrapping with three curly braces:

const String secretApiKey = '{{{NAME_OF_ENV_VAR}}}';

In the example above, the value of NAME_OF_ENV_VAR from your environment will replace {{{NAME_OF_ENV_VAR}}}. If you set the environment, for example using export NAME_OF_ENV_VAR="awesome", the transformer will change the code like so:

const String secretApiKey = 'awesome';

Features and bugs #

Please file feature requests and bugs on

Changelog #

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  replace_env_vars: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:replace_env_vars/replace_env_vars.dart';
Version Uploaded Documentation Archive
0.1.0 Oct 20, 2016 Go to the documentation of replace_env_vars 0.1.0 Download replace_env_vars 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0